Auteur(s) : Jesses Création : 29/09/2006 Mise à jour : 29/09/2006

 

a-squared Free

a-squared Free de Emsisoft est un scanner et destructeur de nuisibles.
Il est spécialisé dans la chasse aux trojans, dialers, spywares, backdoors,...
Il n'est question ici que de la version gratuite (Free). Donc d'un produit qui ne sera utilisé que pour l'analyse et le nettoyage.
Il ne remplacera pas votre antivirus mais le complètera lorsque :
- votre antivirus peine à vous débarrasser d'une bestiole collante et que vous ne vous sentez pas de taille à le faire "à la main" en consultant une base de connaissances.
- vous soupçonnez une infection que votre antivirus ne détecte pas.

Son auteur est renommé. Le produit est efficace.
Le scan en mode sans-échec est possible, le nettoyage est assez complet.
Ce n'est pas un simple outil mais un logiciel, il nécessite une installation (très rapide).

L'objectif de cette page est de vous conduire le plus vite possible à votre premier scan.

Avant de vous décider ou de le conseiller, vérifiez s'il reconnait le nuisible qui vous empoisonne la vie.
La liste des malwares qu'il traite est disponible à l'adresse :
http://www.emsisoft.net/fr/support/malware
Si la sale bête que vous cherchez à neutraliser y figure, vous pouvez vous lancer.
Ne cherchez pas une base de connaissances sur chacun des nuisibles détectés, elle est réduite (pour l'instant ?) à sa plus simple expression.

Le chargement

http://www.emsisoft.net/fr/

Cliquez sur "Téléchargement" dans la barre supérieure. Vous arriverez à la page :
http://www.emsisoft.fr/fr/software/download

Attention ! Ne vous laissez pas piéger !
"a-squared Anti-Malware Personal Edition" payant est toujours proposé en premier, ce n'est qu'une version d'essai.
Descendez sur la page sous le titre "a-squared Free"

Cliquez sur le lien "Démarrez le téléchargement". Le téléchargement va se lancer.
(S'il ne fonctionnait pas, trois autres liens de remplacement vous sont proposés).
Cela vous permet de récupérer le fichier "a2FreeSetup.exe" sur votre disque dur.

L'installation

Si vous possédez une ancienne version de a-squared, désinstallez-la avant d'installer cette version, ce sera plus propre :
Panneau de configuration -> "Ajout/Suppression de programmes".
Sélectionnez "a-squared" -> Bouton "Supprimer"
Puis redémarrez Windows.

Double-cliquez sur le fichier "a2FreeSetup.exe" pour lancer l'installation.

Un numéro par panneau, comme d'habitude.

1 - Choix de la langue d'installation.

Français, bien sûr. Bouton "OK"

2 - Panneau de bienvenue.

Bouton "Suivant >"

3 - Accord de licence.

En anglais !
Je n'y ai rien lu de louche. C'est la licence d'utilisation habituelle.
Cochez "Je comprends et j'accepte les termes du contrat de licence". Ils ont le sens de l'humour !
Bouton "Suivant >"

4 - Dossier de destination.

Il vous propose de l'installer dans le dossier "C:\Program Files\a-squared Free"
Aucune raison de le modifier, bouton "Suivant >"

5 - Sélection du dossier du menu Démarrer.

C'est ce que vous verrez dans le menu "démarrer" -> "Tous les programmes"
"a-squared Free" est proposé.
Tout à fait d'accord. Bouton "Suivant >"

6 - Tâches supplémentaires.

Vous n'allez pas lancer a² toutes les cinq minutes ! Il est accessible par le menu "démarrer".
Mes propositions :

"Mettre un raccourci sur le bureau". A moins que vous n'aimiez les bureaux encombrés. Décochez.
"Mettre un raccourci dans la barre de lancement rapide". Si on y mettait tous les programmes que l'on installe !
"Organiser des scannes par l'intermédiaire du menu contextuel".
(Pratique si vous désirez scanner un fichier ou un dossier par un clic bouton droit de la souris).
Bouton "Suivant >"

7 - Prêt à installer.

Bouton "Installer". Laisser-le poursuivre son installation. C'est assez rapide.

8 - Fin de l'installation.

Décochez "Launch a-squared Free".
Puis cliquez sur le bouton "Terminer"

Le premier contact.

Lancez le logiciel

"démarrer" -> "Tous les programmes" ou "Programmes" -> "a-squared Free" -> "a-squared Free"

Le logiciel s'ouvre sur le panneau "Statut de sécurité".

Le panneau "Statut de sécurité"


La sélection du panneau

A gauche de la fenêtre, on la trouve sur tous les panneaux du logiciel :

- "Statut de sécurité" -> Ce panneau
- "Scanner l'ordinateur" -> Le panneau de choix du scan.
- "Quarantaine" -> Le panneau de gestion de la quarantaine.
- "Aide" -> Vous connecte à la page d'aide de Emsisoft.
Ce dernier bouton affiche dans votre navigateur la page : http://www.emsisoft.net/fr/info/a2/
Cette aide en français est très bien faite. Elle concerne surtout la version complète, mais on y trouve ce que l'on souhaite.

Les commandes du panneau

Dans la partie centrale.

- Bouton "Examiner l'ordinateur maintenant" : joue le même rôle que "Scanner l'ordinateur", affiche le panneau de choix du scan.
- "Remise à zéro du compteur" : réinitialise le compteur du nombre d'objets trouvés.
- "faire la mise à jour" : Très important ! Puisque a-squared Free ne possède pas de mise à jour automatique.
- "Réglages pour la mise à jour" : Nous ne l'utiliserons qu'une fois puisque ces choix seront mémorisés.

Les autres commandes

Ce sont pour l'essentiel des liens vers le site Emsisoft :
- Acces à différentes rubriques du site.
- Les dernières informations (actualisées lors de la mise à jour).
- Une pub pour a-squared Anti-Malware (la version complète payante).

Les réglages

Peu de choses à faire, c'est un modèle de simplicité.

A la rubrique "a-squared Free", cliquez sur "Réglages pour la mise à jour"
Vous avez là les réglages principaux des mises à jour. Ce que je vous propose, à vous de voir :

"Installer le programme d'aide"
Sensé charger les fichiers d'aide lors de la mise à jour. Je les cherche encore mais bon... Peut-être qu'un jour...

"Installez les linguistiques supplémentaires"
Si cette option est décochée, seule la mise à jour de la langue utilisée sera effectuée.
Pourquoi devrions mettre à jour les autres langues ?

"Installer les mises à jour Beta".
Cet article est décoché par défaut.
Les mises à jour Beta sont des mises à jour en phase de test. Donc pas forcément très fiables.

"Communiquer les noms des Malwares trouvés"
Vous communiquez à Emsisoft ce qui a été trouvé sur votre poste. C'est simplement dans un but statistique.

C'est tout pour les réglages !

En haut à droite du panneau "Statut de sécurité", vous voyez "Choose your language...".
Il parle déjà français donc rien à modifier sauf si vous désirez définir une autre langue.
A chaque démarrage ou mise à jour, il vous affichera "Choose your language...", c'est normal.

La mise à jour

Sur le panneau "Statut de sécurité", cliquez sur le bouton "faire la mise à jour"
Si une ou des mises à jour sont disponibles, elles se chargent automatiquement.
Ceci fait, vous pouvez revenir au panneau précédent en cliquant en bas sur "Retour au panneau de sécurité".

Important !

A-Squared Free ne se met pas à jour automatiquement.
Pensez à effectuer la mise à jour avant de lancer une séance de scans.

 

Le scan

Si vous êtes sûr que a-squared est à jour, vous pouvez vous lancer.
Cliquez sur le bouton "Scanner l'ordinateur" pour accéder au panneau de choix du scan.

Le choix du scan

Choisissez un mode de scan.

Scan Rapide

Seuls les programmes actifs (les processus) seront examinés.
Une recherche de spywares et de cookies traceurs (tacking cookies) sera lancée.

Scan rusé

Le scan se fera dans les dossiers importants du système. Donc là où la majorité des nuisibles s'installe.
Les programmes actifs (les processus) seront examinés.
Une recherche de spywares et de cookies traceurs (tacking cookies) sera lancée.
Il est bien suffisant dans la majorité des cas. C'est le meilleur rapport vitesse/efficacité.

Scan Détail

Il est bien sûr beaucoup plus long puisque chaque fichier est examiné. Il faudra donc être très patient...
C'est le mode de scan que vous devrez choisir lorsque vous soupçonnez ou traitez une infection.

Propre Scan

Quand vous cliquerez sur le bouton "Scan", vous pourrez ajouter ou enlever des disques ou dossiers à scanner.
Par défaut, tous les disques et partitions disponibles sont indiqués.
Quand un disque est indiqué tout ce qu'il contient sera analysé. Il est donc inutile d'ajouter l'un de ses dossiers.
Quand un dossier est indiqué, tous ses sous-dossiers seront scannés.
Cliquer sur le bouton "Suivant" lancera le scan que vous avez paramétré.

Les exceptions

Si vous le souhaitez, vous pouvez décider de ne pas scanner certains dossiers.
Cela peut se produire parce que vous les savez sains ou parce que a-squared y produit en permanence de fausses détections.
Je pense par exemple aux quarantaines d'antivirus ou d'autres antispywares.

Vous trouverez également dans ce panneau ce que vous avez exclu lors du scan.

Cliquez en bas de la fenêtre sur "Editer les exceptions"

Un petit formulaire s'ouvre.
Cliquez sur le bouton "..." pour lui désigner le dossier à ne pas scanner dans le formulaire habituel de sélection de dossiers.
Cliquez sur le bouton "Ajouter" pour... ajouter ce dossier à la liste.
Vous pourrez supprimer l'une des exceptions par la suite en la sélectionnant puis en cliquant sur le bouton "Supprimer"
Pensez à cliquer sur le bouton "OK" pour mémoriser vos réglages.

Lancer le scan

On ne peut plus simple : cliquer sur le gros bouton rond "SCAN"
Le scan est immédiatement lancé (sauf pour le scan "Propre Scan")
Quand le scan est terminé, s'il y a des détections, passez au chapitre nettoyage.

Le scan d'un dossier individuel

a-squared a ajouté un article dans le menu contextuel.
Affichez un dossier dans le poste de travail ou l'Explorateur Windows.
Clic bouton droit sur ce dossier -> "Scan with a-squared Free "

Il lancera le scan de la mémoire puis ne scannera que le contenu de ce dossier.
Utile si vous venez de charger un logiciel ou désirez vérifier votre dossier de téléchargement.
S'il détecte quelque-chose, passez au chapitre nettoyage.

Le nettoyage

Le résultat du scan est affiché

Pour chacune de ces détections, vous pouvez cliquer sur le "+" placé devant "Afficher tous les objets trouvés..." pour en avoir le détail.

Laissez cochées les détections que vous désirez nettoyer et décochez ce que vous désirez conserver.

Il n'est pas possible de sélectionner un objet particulier dans une détection. C'est tout ou rien.

Que faut-il cocher ?

- Utilisateurs de ShadowsUser, attention !
Si "vsmvhk.dll" est détecté comme "Backdoor.win32SnoooperYB.c" ne cochez pas cette détection !

Vous risquez le gros plantage de Windows.

- Utilisateurs de Securitoo ou F-Secure. Attention !
Si leur BackWeb était détecté, n'acceptez pas sa suppression..

Il est absolument nécessaire pour effectuer les mises à jour de ces logiciels.
Il est facile à reconnaitre, il suffit de vérifier le chemin du fichier détecté.
Exemples :
ou C:\Program Files\Securitoo\av_fw\backweb\...
ou C:\Program Files\AntivirusFirewall\Program\backweb\...
Diagnostic : Adware.BackWeb.a
Il est ici évident que ce "BackWeb" appartient à Securitoo puisqu'il est dans son dossier d'installation.

Ce n'est qu'une mesure de précaution. A la date de rédaction de cette page, a-squared ne le détecte pas mais cela pourrait se produire à l'occasion d'une mise à jour de sa base de détections.

Faites attention a-squared est chatouilleux. Suivant les mises à jour, son parcours est émaillé de fausses détections. Il en a voulu pendant un moment à l'Espace Wanadoo/Orange, au Backweb de Securitoo,...
Si vous avez un doute, il vaut mieux demander d'abord sur les forums.
Ou patientez jusqu'à la mise à jour suivante. Il réparent habituellement dans la semaine.

Cas des Riskware.RiskTools

Ce sont des cas à part. Ces détections sont relatives à des outils qui pourraient être nuisibles s'ils étaient utilisés dans une mauvaise intention.
Encore faut-il savoir qui les utilise !
Le premier élément de réponse est le chemin du fichier détecté.
Dans l'exemple affiché ci-dessus, le programme en ligne de commande "Process.exe" et utilisé pour interrompre un processus. Dans la mesure où il a été trouvé dans le fichier Archive de SmitFraudFix, un outil de nettoyage du nuisible SmitFraud, son utilisation est tout à fait légale.
De toute façon, si l'un de ces outils est utilisé par un malware, éradiquer le malware supprime le risque.

Conclusion : Dans la majorité des cas, décochez ce type de détection.

Un peu de lecture :
http://www.emsisoft.fr/fr/kb/articles/tec060926/

Les trojans, spywares, dialers, tracking cookies,...

Ce sont des nuisibles avérés, cochez sans état d'âme.
En cas de problème, a-squared permet de restaurer les objets supprimés à partir de sa quarantaine.

Si vous avez un doute

- Cliquer sur la détection vous affiche l'article de la base de connaissances dans le navigateur.
Vous devez bien sûr être connecté, ce qui est à éviter quand on chasse la bestiole et impossible en mode sans-échec.
N'en attendez pas de miracles, cette base de connaissances est réduite à sa plus simple expression et en anglais.

- Obtenir une aide sur un forum.
Cliquez sur le bouton "Enregistrer le rapport".
Vous pouvez communiquer le copier/coller du contenu de ce rapport sur un forum pour solliciter des avis.
Voyez le chapitre "Le fichier rapport"

Exclure une détection

Vous serez peut-être lassé de décocher constamment les même détections.
Il suffit de les placer dans les exceptions.

Clic bouton droit sur la détection -> "Ajouter dans les exceptions"
Il n'est pas possible d'exclure un objet individuel d'une détection.

N'oubliez pas de décocher l'objet si vous envisagez de nettoyer maintenant.

Vous retrouverez cette détection dans le panneau d'exception (voir "Les exceptions" dans le paragraphe précédent)

Le nettoyage

Vous avez maintenant deux choix :

Objets choisis en quarantaine

C'est le choix le plus sûr. Je vous le conseille très fortement.
Les objets sont d'abord sauvegardés en quarantaine de façon à pouvoir les récupérer en cas de problème.
Puis ils sont supprimés.
La quarantaine est dans le dossier "C:\Program Files\a-squared Free\Quarantine\"
Les fichiers y sont copiés dans un format spécifique ".A2Q". Ils ne peuvent plus nuire.

Supprimer les objets choisis

Là, il vaut mieux savoir ce que vous faites ! Les objets sont définitivement supprimés.
Je vous déconseille fortement cette option.

Enregistrer le rapport

Si vous souhaitez conserver une trace de ce qui a été détecté et les actions entreprises, vous pouvez cliquer maintenant sur ce bouton.
Voyez le chapitre "Le fichier rapport"

En cas de problème, la quarantaine

Vous pourrez revenir en arrière si vous avez mis les objets en quarantaine.
Cliquez sur le bouton d'accès au panneau "Quarantaine"

Il suffit de sélectionner l'objet à restaurer (cliquer dessus) puis de cliquer sur le bouton "Restaurer"
Il disparait alors de la zone de quarantaine et reprend sa place primitive.

Il est inutile de conserver là des objets en quarantaine pendant une éternité.
On peut considérer qu'une fois que le poste a été testé sans problème constaté, la quarantaine peut être nettoyée.
S'il faut définir une durée de conservation, disons qu'il est inutile de conserver les objets en quarantaine pendant plus d'un mois.

Le fichier Rapport

Sauvegarder le fichier rapport

Lorsque vous cliquez sur le bouton "Enregistrer le rapport" il vous est proposé de sauvegarder le fichier rapport.
Vous pouvez cliquer sur ce bouton avant ou après traitement des détections.

Le formulaire habituel de gestion de fichier s'ouvre.
Vous n'avez normalement rien à modifier, cliquez sur le bouton "Enregistrer"

Le rapport sera sauvegardé par défaut dans le dossier "Mes documents\a-squared Free\Reports\"
C'est un fichier texte dont le nom est proposé sous la forme : a2scan_aammjj-hhmmss.txt

"aammjj-hhmmss" est la date et l'heure de début du scan.
aa = année sur 2 chiffres, mm = mois sur deux chiffres, jj = jour sur deux chiffre,
hh = heure sur deux chiffres, mm = minutes sur deux chiffres, ss = secondes sur deux chiffres.
Exemple : a2scan_060802-200301.txt

Le rapport s'affiche automatiquement dans le bloc-notes.

Comment communiquer ce rapport sur un forum

Retouver le fichier rapport :

Si vous avez fermé le fichier rapport ouvert automatiquement lorsque vous cliquez sur le bouton "Enregistrer le rapport", il faudra le retrouver.

Utilisez le poste de travail ou l'Explorateur Windows
Ouvrez le dossier "Mes documents\a-squared Free\Reports\"
Double-cliquez sur le fichier rapport correspondant à la date du scan.
Il s'affiche dans le bloc-notes de Windows.

Dans le bloc-notes :

- Menu "Edition" -> "Sélectionner tout"
Tout le contenu de la fenêtre est sélectionné (il passe en bleu).

- Puis à nouveau Menu "Edition" -> "Copier"
Vous ne verrez rien se produire mais le contenu du rapport aura été copié dans le "presse-papiers", prêt à être collé où bon vous semble.
Vous pouvez fermer le bloc-notes.

Sur le forum :

- Agissez comme d'habitude pour rédiger ou répondre à un message.

- Tapez comme d'habitude votre message puis appuyez sur la touche [Entrée] du clavier pour passer à la ligne suivante.

- Placez le curseur à l'endroit où vous désirez insérer l'adresse où votre rapport est visible puis collez :
Clic bouton droit de la souris -> "Coller"

- Si vous le désirez, avant d'envoyer le message, vous pouvez appuyer sur la touche [Entrée] du clavier puis taper encore quelques lignes à la suite.

- Il n'y a plus qu'à envoyer.

La désinstallation

D'abord la désinstallation classique

Deux façons d'y accéder.

Ou "démarrer" -> "Tous les programmes" ou "Programmes" -> "a-squared Free" -> "Uninstall a-squared Free"
Ou Panneau de configuration -> "Ajout/Suppression de programmes" -> Sélectionnez "a-squared Free 2.0" -> Bouton "Supprimer"

La boîte d'alerte de confirmation s'affiche, cliquez sur "Oui"
La désinstallation se lance et le message habituel s'affiche : "Vous devez redémarrer l'ordinateur...".
Acceptez (bouton "Oui").

La page http://www.emsisoft.net/fr/info/uninstall/? s'affiche dans votre navigateur.
Il s'agit d'un formulaire vous demandant pourqui vous avez désinstallé le logiciel.
Sauf si vous êtes très fâché, il n'est absolument pas nécessaire de le remplir.
Fermez votre navigateur.

Finir la désinstallation

Utilisez le poste de travail ou l'Explorateur Windows.

Ouvrez le dossier "C:\Program Files\"
Supprimez le dossier "a-squared Free"

Ouvrez le dossier "Mes documents"
Supprimez le dossier "a-squared"

Si vous le souhaitez (peu important) :
Ouvrez le dossier C:\WINDOWS\Prefetch\
Supprimez les fichiers A2FREE.EXE-xxxxxxxx.pf et A2FREESETUP.EXE-xxxxxxxx.pf
(les xxxxxxxx sont des caractères quelconques).

Pour le reste, rien dont CCleaner ne peut venir à bout.

Pour les experts seulement

Ce sont des traces sans grande importance dans la base de registre.

Clé HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\
Suprimez la sous-clé "a2FreeContMenu"

Clé HKEY_CLASSES_ROOT\CLSID\
Supprimez la clé {A155339D-CCCD-4714-85EB-3754B804C9DF}

Clé HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandlers\
Supprimez la clé "a2FreeContMenu"

HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\
Supprimez la clé " a2FreeContMenu"

Clé HKEY_LOCAL_MACHINE\SOFTWARE\
Supprimez la sous-clé "Emsi Software GmbH" si vous n'avez pas d'autre logiciel Emsisoft.
Sinon ne supprimez que la sous-clé "\a-squared".

J'envisage d'écrire un script bfu pour automatiser le complément de nettoyage. A suivre...

Compléments

Les différences entre "a-squared Free" (gratuit) et "a-squared Anti-Malware" (payant)
http://www.emsisoft.fr/fr/info/a2/compare.htm
La version complète se distingue surtout par son "Gardien d'arrière plan" qui protège en temps réel.
La mise à jour est automatique.

A-squared propose un scan en ligne :
http://www.emsisoft.fr/fr/software/ax/
J'avoue ne pas l'avoir encore testé.

 

Jesses Entraide. Création 03/2005